Bug 232 : freeze on stop of running sketch
Last modified: 2006-10-21 08:58



Joseph Piche
Assigned To:

Attachment Type Created Size Actions

Description:   Opened: 2005-11-29 23:04
Almost every time I run a sketch, when I close out of the running sketch,
the PDE freezes. In order to get around it I have to force quit out of the
PDE and reopen it. This does not seem to be dependant of any code, but I'm
fairly new at processing and could be wrong.

I am using windows XP on a pentium 4 HyperThreading processor. The HT has
been quirky with other things, so it could just be my processor.

I haven't tried building it from source yet and trying that.
Additional Comment #1 From fry 2005-11-30 06:54
hm, sounds like a problem with the multithreading setup with HT machines. i have a dual
processor box i can test it on and i'll see if i can get something to reproduce.

what versions is this happening on? for instance, does it happen with recent versions as well
as release 0090 (after which some significant changes to threading were made).
Additional Comment #2 From Joseph Piche 2005-11-30 11:46
I tried using 0090 like you sugested and I ran across some of the same
problems. What I did was go through a lot of the example sketches on 0090,
0096, and 0097. One in particular that made the PDE freeze on closing the
running sketch was GUI->Scrollbar.

When I went back through and made sure I wasn't crazy, I found that some of
the more simpler example (fewer lines of code) seemed to work. One that did
work was 3D-Form->RBG Cube.

Also, I thought this may be related to Bug #126. However, it may not.
Additional Comment #3 From fry 2005-11-30 12:15
interesting.. can you try shutting off hyperthreading in the bios and
confirm that it's an issue with having (emulated) multiple processors?
Additional Comment #4 From Joseph Piche 2005-11-30 12:53
When I disabled HT, I still had the same issues. Maybe it's something else.
Additional Comment #5 From fry 2005-11-30 12:55
nuts, and you're sure you completely disabled HT (i.e. went to task
manager, saw a single processor running, ran sketches and they took up 50%
cpu instead of 100%)?
Additional Comment #6 From Joseph Piche 2005-11-30 22:22
Yes, I made sure that HT was completely disabled. Also, this has happened
to me without quicktime installed and with quicktime 6 and 7. I do have
J2SE Runtime Enviroment 5.0 Update 4 installed as well, but i'm not sure if
that's even relevant.
Additional Comment #7 From fry 2005-12-01 05:21
have you tried it with the version of processing that includes java?
Additional Comment #8 From Joseph Piche 2005-12-07 14:40
I normailly use the verson with Java, but I did check it in the versions
without and it still has that same problem. To discribe the problem a
little more:

When I run a sketch it opens the Java window and it runs fine. If I go to
the PDE and hit the stop button, nothing happens. If I decide to close the
sketch window, it closes fine, but the PDE then freezes. Everything else on
my computer still works, and I can even drag the window around, but the
window has nothing in it except the grayish background. If I click the "X"
then it closes fine, and if I haven't saved the sketch it brings up the
"are you sure" box, but that is blank except for the title on the dialog box.

I must admit, this seems like a strange problem. And because it is anoying,
I will do whatever I can to help you out.
Additional Comment #9 From fry 2005-12-08 10:06
i haven't been able to get this to reproduce on a machine here yet.. i'll
try with a dual processor box when i get a chance, but these are nasty
sorts of issues to try and figure out, particularly if i can't get it to
break on one of my own machines. lemme see if i can get it to break somewhere.
Additional Comment #10 From Joseph Piche 2005-12-11 16:49
I've been able to try it on 3 or 4 other Pentium 4 HT machines with XP, and
I was not able to reproduce the problem. I also tried compiling from source
and that didn't do anything diferent. Then I thought that a fresh install
of windows might make a difference, so I formatted and tried it again, but
that seemed to make things worse. Now when I close a running sketch, the
whole computer locks up and doesn't come back.

I read in the forums that you can use other editors with Processing. Are
there any other editors that allow you to run sketches like the PDE does? I
feel like I may just have to seach for other options.
Additional Comment #11 From fry 2005-12-12 16:34
i'm not sure what to tell you... there are instructions on how to use eclipse on the
"integration" section of the discourse page, if you want to go that route.

though i'm quite baffled about what you're running into. the fact that you've reformatted the
machine and reinstalled windows and are still getting the problem seems to tell me that
there's a much stranger problem.

can you think of anything that's different about this machine than the others? weird graphics
card? less ram? older version of xp? virus scanning software installed? non-english version of

also, for testing i highly recommend that you use the version that includes java to at least
eliminate that variable. there are lots of issues with java 1.5 so we want to isolate it from
being a problem with that.
Additional Comment #12 From Joseph Piche 2005-12-15 13:03
Well, I've done a whole bunch of tests to see what could be the problem and
I think I found it.

First, since I have a dual boot with Linux (Gentoo) I decided to download
the Linux verson. That worked perfectly: no problems whatsoever.

Next I ran extensive RAM tests (Memtest86+ v.1.60) and discovered that one
of two sets of 256MB dual channel DDR2 sticks are bad. So I double checked
that it wasn't the RAM slots on the motherboard and when I ran PDE in
windows again, I still had the same problems.

At this point I was very confused. The only thing left to try was the video
card. I have a nVidia GeForce 6600GT _PCI-E_ card. I took it out and put in
an old ATI RAGE PRO _PCI_ card. The PDE then worked fine.

So, I don't know if it's a problem with the nVidia drivers, how Java treats
PCI-E, how the PDE treats PCI-E, or that the card is going bad, but the
problem has something to do with that card.

And if it helps I am running diferent versions of the nVidia driver on
Linux and Windows. On Linux it's verson 71 and and windows it's 81.

I hope all this helps.
Additional Comment #13 From Joseph Piche 2005-12-15 13:21
I feel really dumb now. I fixed my problem; I had anti-aliasing turned on.
Once I turned it to application-controled instead of 2X, it worked fine. I
found out that there is a problem with how Java works with anti-aliasing,
and that many people run into this. Sorry about all the hassle.
Additional Comment #14 From youn 2006-10-21 08:58
when i run this program, it is disappeard right away