Bug 981 : processing gui doesn't start (some wrong path?)
Last modified: 2009-08-13 14:52

DUPLICATE of bug 825


Assigned To:

Attachment Type Created Size Actions

Description:   Opened: 2008-10-23 06:57
tried with both version 0148 and 0154

# /path/to/processing-0154/processing
Exception in thread "main" java.lang.NoClassDefFoundError: processing/app/Base
Caused by: java.lang.ClassNotFoundException: processing.app.Base
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
Additional Comment #1 From fry 2008-10-23 07:04
cd /path/to/processing-0154 && ./processing
Additional Comment #2 From worf 2008-10-23 08:40
(In reply to comment #1)
well, if it is really necessary to first change into the processing directory,
then the wrapper script should handle that.

which however leads to another problem: if i'm changing the working directory,
all dialogs for opening and saving files are starting in that dir, causing
grave pain to the user who tries starts processing from some project dir and
has to click back to what is supposed to be his working dir every time he
wants to use a file open/save dialog.
Additional Comment #3 From pajaja 2008-11-18 06:50
i had a same problem, and i created another shell script in the same folder
for executing the main script :D
lame solution but it works...
Additional Comment #4 From fry 2008-11-24 12:36
That's what this line should be doing:

APPDIR="$(dirname -- "${0}")"

Though that was contributed by someone else who claimed it worked. If
that's not the case, please let us know.
Additional Comment #5 From fry 2009-08-13 14:52

*** This bug has been marked as a duplicate of 825 ***