Bug 1409 : Processing crashes on startup on Mac after Java update
Last modified: 2009-12-11 13:30



Assigned To:

Attachment Type Created Size Actions

Description:   Opened: 2009-12-11 12:47
I'm on OS X 10.6.2, MacBook Pro 2.6 Ghz i386, using Processing 1.0.9.

After i installed the latest Java update from Apple, Processing no longer
starts up without crashing.

I tried removing the preferences file, open a different sketch on startup,
move my Sketches directory, and upgraded from Processing 1.0.5 to the
latest 1.0.9.
I've changed the Java Preferences from 32 to 64 bits and back, for both 1.5
and 1.6.

The error I keep getting is:
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread: 4

Thread 0: Dispatch queue: com.apple.main-thread
0 libSystem.B.dylib 0x9112d8da mach_msg_trap + 10
1 libSystem.B.dylib 0x9112e047 mach_msg + 68
2 com.apple.CoreFoundation 0x9498477f __CFRunLoopRun + 2079
3 com.apple.CoreFoundation 0x94983864 CFRunLoopRunSpecific + 452
4 com.apple.CoreFoundation 0x94983691 CFRunLoopRunInMode + 97
5 ...ple.JavaApplicationLauncher 0x0000958e
startupJava(LauncherArgsStruct*) + 342
6 ...ple.JavaApplicationLauncher 0x000088cf launchJavaApplication + 1355
7 org.processing.app 0x00002c29 0x1000 + 7209
8 org.processing.app 0x000028d2 0x1000 + 6354
9 org.processing.app 0x000027ed 0x1000 + 6125

(let me know if you want more stack traces or diagnostics)

I'm not 100% this is related to the Java update, but things started going
wrong shortly after I installed it.

I tried starting up Processing by setting the classpath (as per the
Info.plist) and doing
java processing.app.Base
(with java version "1.6.0_17")
This works fine, or at least it doesn't crash. I haven't tried using JNI
libs this way though, I suspect that won't work.

I searched around expecting to see similar error reports but found nothing.
Am I the only one seeing this problem?

best regards,

Additional Comment #1 From fry 2009-12-11 12:49
This is the result of installing Java 1.5 on Snow Leopard, not a Processing
Additional Comment #2 From fry 2009-12-11 12:53
Or rather, Apple's Java engineers have stated that this is a telltale sign
of installing 1.5 on Snow Leopard, and what can happen. I can't say for
certain that's what it is, but it's safe to assume that's what's happening.
Additional Comment #3 From marser 2009-12-11 13:30
Wow, that was quick - 2 mins!

I tried changing the Info.plist to force the launcher to use Java 1.6, and
that seems to work fine.

So if anyone else has the same problem, the solution is:

Edit /Applications/Processing.app/Contents/Info.plist


Many thanks for the quick reply.