Bug 1285 : Bug 986 on Processing 1.0.5 Launch4j error, stated modul was not found
Last modified: 2009-07-06 21:06



Assigned To:

Attachment Type Created Size Actions

Description:   Opened: 2009-07-03 11:01
hello togeher,
i am using processing 1.0.5 since yesterday. Everything worked fine and i
wrote some sketches. But today processing won't start anymore, giving me
the same error as Bug 986.
http://dev.processing.org/bugs/long_list.cgi?buglist=986 which i'll quote here:

" i had this error on two windows-xp computers (pentium4 and athlonxp).
after launching processing the loading screen shows up and after about a
minute this message shows up in a windows-popup-window:
"Launch4j | An error occurred while starting the application"

after pressing ok the loading screen disappears but the javaw.exe process
is still running in the taskmanager. for every restart of processing a new
javaw.exe process starts. "

here is my "processing.exe --l4j-debug" log:
CmdLine: G:\processing-1.0.5\processing.exe --l4j-debug
WOW64: no
Working dir: G:\processing-1.0.5\.
Bundled JRE: java
Check launcher: G:\processing-1.0.5\java\bin\javaw.exe (OK)
Add classpath: lib\pde.jar
Add classpath: lib\core.jar
Add classpath: lib\jna.jar
Add classpath: lib\ecj.jar
Add classpath: lib\antlr.jar
Launcher: G:\processing-1.0.5\java\bin\javaw.exe
Launcher args: -Xms128m -Xmx128m -classpath
Args length: 156/32768 chars
Error: Das angegebene Modul wurde nicht gefunden. (means stated modul
wasn't found)

tried everything, updated java, reinstalled jave.... nothing. here's my
java version:

java version "1.6.0_14"
Java(TM) SE Runtime Environment (build 1.6.0_14-b08)
Java HotSpot(TM) Client VM (build 14.0-b16, mixed mode, sharing)

also tried version 1.0.3, same problem, changed folder name of the last

i noticed that i have no preference.txt in a personal folder, only the one
in the /lib

i am using winXP SP1 german.

any help is greatly apreciated,
Additional Comment #1 From fry 2009-07-06 08:14
sounds like a bad preferences.txt file.. do a full search of your system
for preferences.txt and remove it, then try restarting processing.
Additional Comment #2 From l0c0mat 2009-07-06 13:46
already tried this, was no help.

reinstalled xp, was an old system, fixed the prob.

thx anyway, great software!