Bug 1267 : Tab key does not function properly in editor
Last modified: 2009-06-07 16:00



Assigned To:

Attachment Type Created Size Actions

Description:   Opened: 2009-06-05 09:09
When I press the TAB-key I expect to insert a number of spaces. However,
since 1.0.4 the focus is removed from the text editor to somewhere else.

I tried with a fresh 1.0.4-with-java on Windows XP.

The preferences file is standard:
# convert tabs to spaces? how many spaces?
editor.tabs.expand = true
editor.tabs.size = 2
Additional Comment #1 From bredend 2009-06-05 09:12
I just discovered that the focus is moved to the console at the bottom of
the window.
Additional Comment #2 From Conor Peterson 2009-06-05 09:23
Seeing this exact same behavior on the Mac version as well.

Processing 1.0.4
MacOS X 10.5.7, JavaTester.org says my JRE is "1.5.0_16 from Apple Inc."

Version 1.0.3 worked okay.
Additional Comment #3 From fry 2009-06-05 14:46
wow, that's major. i'm surprised you're the first person to report it. i'll
have to get 1.0.5 out asap.
Additional Comment #4 From PhiLhoČ 2009-06-06 12:48
Searched the problem before reporting it...
So I just confirm, for 1.0.4, WinXP Pro SP3, Java 1.6.0_13.
Additional Comment #5 From fry 2009-06-06 12:53
yeah, thanks.. i know what the problem is--i had removed some deprecated
focus code from the editor--but unfortunately it had in fact been
functioning. i'll get a fix out asap.
Additional Comment #6 From fry 2009-06-07 14:07
fixed for 1.0.5.