Bug 1016 : Processing cannot run because it could not create a folder to store your settings
Last modified: 2010-03-12 07:55



Assigned To:

Attachment Type Created Size Actions

Description:   Opened: 2008-11-18 16:36
Launching processing-0148 and processing -0156 fail because they cannot create a
folder to store settings.

I am running vista on a lenovo T61p thinkpad. Processing has run previously on
this system, though a whole slew of updates have been thrust upon vista since I last
ran it.

Is there a log file that would capture information about this error?
Additional Comment #1 From fry 2008-11-18 18:09
That means it cannot write to the Application Data (or AppData) folder on
your machine. Is there something about your machine's setup that would
prevent this? (e.g. it's a lab machine, or has a roaming setup, or is
strictly controlled by your IT department.)

The location is pointed to by the Registry key

Please make sure the directory location stored at that registry key is
Additional Comment #2 From fry 2008-11-24 12:37
Did you find the problem?
Additional Comment #3 From billyhill 2008-11-24 13:48
(In reply to comment #2)
> Additional Comment #2 From fry 2008-11-24 12:37 [reply] Did you find the

I don't know if I fixed the problem, but I did find a work around. I edited the
preference file and changed the sketchbook.path and settings.path to
c:\processiong\sketch and c:\processing\settings. I had to create the directories
manually, but once i did it worked.

As you suspected this is a lab machine, so there are probably some controls in place
to prevenet me from doing this...

But it looks like I am in now. Thanks for digging into this.
Additional Comment #4 From James90N 2008-12-01 14:44
i had this same problem i am also using vista

worked fine, first time on my xp laptop

time and a half later of reading threads and peoples problems i found an
answer that worked fine, have not had a chance to test on any other vista
machine. So be sure to let me know.

its the only way so far that i have found to get arround it, actvate you
guest account or an account with limited privelages and paste the
processing software on the desktop, and workes fine, first time no problem.

i agree this is irritating however it workes untill a more... propper bug
fix is available

Additional Comment #5 From fry 2008-12-01 14:52
I'd be happy to fix this bug, however I have absolutely no means of
reproducing it. It does not happen on the two Vista machines I have access
to, which makes it impossible for me to fix.

Anyone who can get me a reproducible case for it happening, that would be
great, and I'll happily fix the problem.

And for others, please read comment #1, which describes what I need to know
in order to make this work.
Additional Comment #6 From fry 2009-08-13 14:53
Closing bug, no further reports and no followup.
Additional Comment #7 From p brouwer 2010-03-12 07:55
I'm having this problem too -- my problem was I reinstalled processing to a new
folder, but then Windows wouldn't let me change the file association, neither would it
let me open a PDE file with "Open with..."

I had the problem with the registry key, noted in comments above -- but fixing that
didn't completely clear the problem -- I still couldn't change the file association... and
when I tried to use processing to change the file association -- java crashed -- I have
a crash log file if you're interested... but I think it's an ACL security bug in NTFS -- I
had the same problem with cygwin -- a couple of years back... cygwin also uses a
non-standard installation method -- and the problem started with reinstallation. The
cygwin support people blamed the problem on NTFS/ACL -- and their files for one
reason or another becoming owned by a phantom user. They actually told people not
to avoid installing cygwin on an NTFS file system.

Now I have no choice, I'm running processing on an SD card with a FAT file system,
and without file assocations.